Дополнительные функции для 1С:Документооборот

Публикация № 1183187

Разработка - Практика программирования

документооборот расширение автоподстановки динамические пользовательские

В данной публикации я хочу поделиться расширением, которое содержит дополнительные функции (доработки) для 1С:Документооборот.

Список дополнительных функций:

  • Динамические роли
  • Автоматическое обновление файлов данными владельца
  • Отключение создания задачи ознакомления для бизнес-процесса "Согласование"
  • Отключение создания задачи ознакомления для бизнес-процесса "Утверждение"
  • Отключение создания задачи ознакомления для бизнес-процесса "Регистрация"
  • Запрет повторного запуска комплексного процесса по предмету
  • Пользовательские автоподстановки
  • Ограничение запуска бизнес-процессов по видам внутренних, входящих, исходящих документов

Описание.

Динамические роли.

Данная функция позволяет автоматически подставлять объекты адресации из предмета процесса в роль с объектом адресации. Для добавления новых автоподстановок в адресной книге необходимо нажать кнопку "Обновить автоподстановки":

После обновления появятся автоподстановки для ролей, которые используются с объектами адресации:

Пример использования. 

Допустим у нас есть роль "_Тест":

Исполняет данную роль пользователь "Администратор" по организации "ООО Управляющая компания" и по подразделению "Администрация":

Автоподставнока "_Тест (Роль)" со скришота выше сможет автоматически определить объекты адресации по предмету для роли "_Тест". 

 
 Код модуля "ШаблоныБизнесПроцессов" из расширения

 

Автоматическое обновление файлов данными владельца (//info.perfectdev.ru/public/1120532/).

В расширении изменения объекта проверяются другим способом. Если хотя бы один реквизит из документа изменен, тогда файлы, которые не заняты на редактирование, созданы по шаблону, не помечены на удаление обновляются данными документа.

 

Отключение создания задачи ознакомления для бизнес-процессов "Согласование", "Утверждение", "Регистрация" (//info.perfectdev.ru/public/1161532/).

Данная функция работает только при создании процесса по шаблону. В шаблоне процесса добавлен реквизит "Не создавать задачу ознакомления":

Если значение реквизита равно "Истина", тогда задача "Ознакомиться с результатом согласования" создаваться не будет.

Обновление  2.1.18.11:

Добавлена возможность отключения создания задачи ознакомления для регистрации и утверждения/подписания. Функция работает также как и отключение создания задачи ознакомления для согласования.

 

Запрет повторного запуска комплексного процесса по предмету.

При открытии формы комплексного процесса стоит проверка, если пользователь пытается запустить более 1 комплексного процесса по документу форма нового процесса не открывается и пользователю выдается предупреждение.

 

Настройки расширения находятся в отдельной подсистеме "Дополнительные функции":

Динамические роли включены по умолчанию без возможности отключения.

 

Обновление 2.1.18.1.

Пользовательские автоподстановки.

Добавлена новая функция "Пользовательские автоподстановки". С помощью данной функции можно добавлять собственные автоподстановки для шаблонов бизнес-процессов в режиме предприятия. Пользовательские автоподстановки находятся в подсистеме "Дополнительные функции":

В карточке пользовательской автоподстановки на закладке "Алгоритм" нужно написать программный код автоподстановки. Результат автоподстановки необходимо присвоить переменной "РезультатФункции". В коде можно обращаться к параметрам "Объект" (тип - БизнесПроцессОбъект), "ИмяПредмета" (тип - СправочникСсылка.ИменаПредметов), "ВходящиеЗначения" (значения, которые заполняются на закладке "Входящие значения" помещаются в структуру, к данным значениям можно обращаться в коде как к элементам обычной структуры по ключу):

На закладке "ВходящиеЗначения" можно задать константы, к которым в дальнейшем можно будет обращаться в коде автоподстановки как к элементам обычной структуры (ВходящиеЗначения.тест):

Идею передачи входящих значений заимствовал в публикации //info.perfectdev.ru/public/1111403/.

Технически входящие значения реализованы с помощью реквизита типа "ХранилищеЗначения". В данный реквизит сохраняются данные в виде структуры, которые вводятся в таблице "Входящие значения".

На закладке "Тестирование" можно проверить автоподстановку с нужными параметрами (если они требуются), результат работы кода автоподстановки выводится в список значений:

Технически пользовательские автоподстановки реализованы следующим образом:

- В функции"ПолучитьСписокДоступныхФункций" общего модуля "ШаблоныБизнесПроцессов" добавляются автоподстановки из справочника.

 
 Код добавления автоподстановок:

К имени функции автоподстановки добавляется префикс "ПользовательскаяАвтоподстановка_" для поиска элемента справочника с программным кодом при получении значения автоподстановки.

- В функцию "ПолучитьЗначениеАвтоподстановки" общего модуля "ШаблоныБизнесПроцессов" добавлена дополнительная проверка. В функции автоподстановки выполняется поиск префикса "ПользовательскаяАвтоподстановка_", если данный префикс найден, тогда выполняется поиск элемента справочника пользовательской автоподстановки по наименованию. Далее выполняется программный код элемента справочника. Запись пользовательских автоподстановок с одинаковым наименованием запрещена, поэтому при поиске элемента по наименованию будет найдено не более 1 автоподстановки.

 
 Код дополнительной проверки

 

Обновление  2.1.18.11.

В пользовательскую автоподстановку добавлена возможность прикрепления ссылки на файл (удобно хранить файлы с внешними обработками тестирования и т.д.):

Такой способ является не совсем оптимальным, но через расширение проблематично подключить собственный объект к посистеме хранения файлов, если перенести доработку в основную конфигурацию, то естественно удобнее использовать существующую подсистему хранения файлов.

 

Ограничение запуска бизнес-процессов по видам внутренних, входящих, исходящих документов.

Добавлена возможность ограничения запуска бизнес-процессов по видам внутренних, входящих, исходящих документов. Для того, чтобы включить данную функцию необходимо заполнить таблицу "Недоступные типы процессов для запуска по видам документов":

В таблице заполняется полная роль, подразделение, рабочая группа, пользователь для ограничения запуска определенного типа процесса. С помощью флага "Доступность" можно разрешить доступ определенному пользователю или группе пользователей к типу процесса. Например, если заполнить таблицу следующим образом:

То все исполнители роли "Директор" не смогут запускать указанные типы процессов, а пользователь "Федоров О.П." получит доступ к процессу "Исполнение":

Технически данная функция реализована следующим образом:

- Добавлена процедура "ДФ_ДобавитьВДеревоВариантыСозданияПроцессов" в общий модуль "ПомощникОтправить", которая вызывается после процедуры "ДобавитьВДеревоВариантыСозданияПроцессов" основной конфигурации. В данной процедуре происходит удаление недоступных типов процессов для запуска из дерева значений вариантов отправки согласно настройке.

 
 Код общего модуля "ПомощникОтправить" из расширения

 



#Область ТиповыеПроцедурыИФункции

&После("ДобавитьВДеревоВариантыСозданияПроцессов")
Процедура ДФ_ДобавитьВДеревоВариантыСозданияПроцессов(Помощник) Экспорт
	
	ДФ_ЗаполнитьДеревоВариантовПоПравамДоступа(Помощник)
	
КонецПроцедуры

#КонецОбласти


// Процедура - Д ф заполнить дерево вариантов по правам доступа
//
// Параметры:
//  Помощник - 	 Структура, см. общий модуль "ПомощникОтправить", функция "Помощник" 
//  Изменяет дерево вариантов отправки согласно записям в регистре сведений "ДФ_НедоступныеТипыПроцессовДляЗапуска"
Процедура ДФ_ЗаполнитьДеревоВариантовПоПравамДоступа(Помощник) 
	
	УстановитьПривилегированныйРежим(Истина);
	
	Запрос = Новый Запрос;
	
	//Установка значений параметров
	Запрос.УстановитьПараметр("Пользователь", Пользователи.ТекущийПользователь());
	Запрос.УстановитьПараметр("ОбъектыОтправки", Помощник.ОбъектыОтправки);
	Запрос.УстановитьПараметр("РабочаяГруппаВсеПользователи", Справочники.РабочиеГруппы.ВсеПользователи);
	
	Запрос.Текст = "ВЫБРАТЬ
	|	ДФ_НедоступныеТипыПроцессовДляЗапуска.ВидДокумента КАК ВидДокумента,
	|	ДФ_НедоступныеТипыПроцессовДляЗапуска.ТипПроцесса КАК ТипПроцесса,
	|	МАКСИМУМ(ДФ_НедоступныеТипыПроцессовДляЗапуска.Доступность) КАК Доступность
	|ИЗ
	|	РегистрСведений.ДФ_НедоступныеТипыПроцессовДляЗапуска КАК ДФ_НедоступныеТипыПроцессовДляЗапуска
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
	|			ВнутренниеДокументы.ВидДокумента КАК ВидДокумента
	|		ИЗ
	|			Справочник.ВнутренниеДокументы КАК ВнутренниеДокументы
	|		ГДЕ
	|			ВнутренниеДокументы.Ссылка В(&ОбъектыОтправки)
	|		
	|		ОБЪЕДИНИТЬ ВСЕ
	|		
	|		ВЫБРАТЬ
	|			ИсходящиеДокументы.ВидДокумента
	|		ИЗ
	|			Справочник.ИсходящиеДокументы КАК ИсходящиеДокументы
	|		ГДЕ
	|			ИсходящиеДокументы.Ссылка В(&ОбъектыОтправки)
	|		
	|		ОБЪЕДИНИТЬ ВСЕ
	|		
	|		ВЫБРАТЬ
	|			ВходящиеДокументы.ВидДокумента
	|		ИЗ
	|			Справочник.ВходящиеДокументы КАК ВходящиеДокументы
	|		ГДЕ
	|			ВходящиеДокументы.Ссылка В(&ОбъектыОтправки)) КАК ТаблицаВидыДокументов
	|		ПО ДФ_НедоступныеТипыПроцессовДляЗапуска.ВидДокумента = ТаблицаВидыДокументов.ВидДокумента
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
	|			СведенияОПользователяхДокументооборот.Подразделение КАК Контейнер
	|		ИЗ
	|			РегистрСведений.СведенияОПользователяхДокументооборот КАК СведенияОПользователяхДокументооборот
	|		ГДЕ
	|			СведенияОПользователяхДокументооборот.Пользователь = &Пользователь
	|		
	|		ОБЪЕДИНИТЬ ВСЕ
	|		
	|		ВЫБРАТЬ
	|			РабочиеГруппыСостав.Ссылка
	|		ИЗ
	|			Справочник.РабочиеГруппы.Состав КАК РабочиеГруппыСостав
	|		ГДЕ
	|			РабочиеГруппыСостав.Пользователь = &Пользователь
	|		
	|		ОБЪЕДИНИТЬ ВСЕ
	|		
	|		ВЫБРАТЬ
	|			ИсполнителиЗадач.РольИсполнителя
	|		ИЗ
	|			РегистрСведений.ИсполнителиЗадач КАК ИсполнителиЗадач
	|		ГДЕ
	|			ИсполнителиЗадач.Исполнитель = &Пользователь
	|		
	|		ОБЪЕДИНИТЬ ВСЕ
	|		
	|		ВЫБРАТЬ
	|			&Пользователь
	|		
	|		ОБЪЕДИНИТЬ ВСЕ
	|		
	|		ВЫБРАТЬ
	|			&РабочаяГруппаВсеПользователи) КАК ТаблицаКонтейнерыПользователя
	|		ПО ДФ_НедоступныеТипыПроцессовДляЗапуска.Пользователь = ТаблицаКонтейнерыПользователя.Контейнер
	|
	|СГРУППИРОВАТЬ ПО
	|	ДФ_НедоступныеТипыПроцессовДляЗапуска.ВидДокумента,
	|	ДФ_НедоступныеТипыПроцессовДляЗапуска.ТипПроцесса";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	Если Не РезультатЗапроса.Пустой() Тогда
		
		КоллекцияСтрокВариантов = Помощник.ДеревоВариантов.Строки;
		
		Выборка = РезультатЗапроса.Выбрать();
		
		Пока Выборка.Следующий() Цикл
			
			Если Не Выборка.Доступность Тогда
				
				Если Выборка.ТипПроцесса = Перечисления.ДФ_ТипыПроцессов.Исполнение Тогда
					
					СтрокаДерева = КоллекцияСтрокВариантов.Найти(Справочники.ШаблоныИсполнения.ПоУмолчанию, "Вариант");
					Если ЗначениеЗаполнено(СтрокаДерева) Тогда	
						КоллекцияСтрокВариантов.Удалить(СтрокаДерева);					
					КонецЕсли;
					
				ИначеЕсли Выборка.ТипПроцесса = Перечисления.ДФ_ТипыПроцессов.КомплексныйПроцесс Тогда
					
					СтрокаДерева = КоллекцияСтрокВариантов.Найти(Справочники.ШаблоныКомплексныхБизнесПроцессов.ПоУмолчанию, "Вариант");
					Если ЗначениеЗаполнено(СтрокаДерева) Тогда
						КоллекцияСтрокВариантов.Удалить(СтрокаДерева);
					КонецЕсли;
					
				ИначеЕсли Выборка.ТипПроцесса = Перечисления.ДФ_ТипыПроцессов.Ознакомление Тогда
					
					СтрокаДерева = КоллекцияСтрокВариантов.Найти(Справочники.ШаблоныОзнакомления.ПоУмолчанию, "Вариант");
					Если ЗначениеЗаполнено(СтрокаДерева) Тогда
						КоллекцияСтрокВариантов.Удалить(СтрокаДерева);
					КонецЕсли;
					
				ИначеЕсли Выборка.ТипПроцесса = Перечисления.ДФ_ТипыПроцессов.Приглашение Тогда
					
					СтрокаДерева = КоллекцияСтрокВариантов.Найти(Справочники.ШаблоныПриглашения.ПоУмолчанию, "Вариант");
					Если ЗначениеЗаполнено(СтрокаДерева) Тогда
						КоллекцияСтрокВариантов.Удалить(СтрокаДерева);
					КонецЕсли;
					
				ИначеЕсли Выборка.ТипПроцесса = Перечисления.ДФ_ТипыПроцессов.Рассмотрение Тогда
					
					СтрокаДерева = КоллекцияСтрокВариантов.Найти(Справочники.ШаблоныРассмотрения.ПоУмолчанию, "Вариант");
					Если ЗначениеЗаполнено(СтрокаДерева) Тогда
						КоллекцияСтрокВариантов.Удалить(СтрокаДерева);
					КонецЕсли;
					
				ИначеЕсли Выборка.ТипПроцесса = Перечисления.ДФ_ТипыПроцессов.Регистрация Тогда
					
					СтрокаДерева = КоллекцияСтрокВариантов.Найти(Справочники.ШаблоныРегистрации.ПоУмолчанию, "Вариант");
					Если ЗначениеЗаполнено(СтрокаДерева) Тогда
						КоллекцияСтрокВариантов.Удалить(СтрокаДерева);
					КонецЕсли;
					
				ИначеЕсли Выборка.ТипПроцесса = Перечисления.ДФ_ТипыПроцессов.Согласование Тогда
					
					СтрокаДерева = КоллекцияСтрокВариантов.Найти(Справочники.ШаблоныСогласования.ПоУмолчанию, "Вариант");
					Если ЗначениеЗаполнено(СтрокаДерева) Тогда
						КоллекцияСтрокВариантов.Удалить(СтрокаДерева);
					КонецЕсли;
					
				ИначеЕсли Выборка.ТипПроцесса = Перечисления.ДФ_ТипыПроцессов.ОбработкаВнутреннегоДокумента Тогда
					
					СтрокаДерева = КоллекцияСтрокВариантов.Найти(Справочники.ШаблоныСоставныхБизнесПроцессов.ОбработкаВнутреннегоДокументаПоУмолчанию, "Вариант");
					Если ЗначениеЗаполнено(СтрокаДерева) Тогда
						КоллекцияСтрокВариантов.Удалить(СтрокаДерева);
					КонецЕсли;
					
				ИначеЕсли Выборка.ТипПроцесса = Перечисления.ДФ_ТипыПроцессов.ОбработкаВходящегоДокумента Тогда
					
					СтрокаДерева = КоллекцияСтрокВариантов.Найти(Справочники.ШаблоныСоставныхБизнесПроцессов.ОбработкаВходящегоДокументаПоУмолчанию, "Вариант");
					Если ЗначениеЗаполнено(СтрокаДерева) Тогда
						КоллекцияСтрокВариантов.Удалить(СтрокаДерева);
					КонецЕсли;
					
				ИначеЕсли Выборка.ТипПроцесса = Перечисления.ДФ_ТипыПроцессов.ОбработкаИсходящегоДокумента Тогда
					
					СтрокаДерева = КоллекцияСтрокВариантов.Найти(Справочники.ШаблоныСоставныхБизнесПроцессов.ОбработкаИсходящегоДокументаПоУмолчанию, "Вариант");
					Если ЗначениеЗаполнено(СтрокаДерева) Тогда
						КоллекцияСтрокВариантов.Удалить(СтрокаДерева);
					КонецЕсли;
					
				ИначеЕсли Выборка.ТипПроцесса = Перечисления.ДФ_ТипыПроцессов.Утверждение Тогда
					
					СтрокаДерева = КоллекцияСтрокВариантов.Найти(Справочники.ШаблоныУтверждения.ПоУмолчанию, "Вариант");
					Если ЗначениеЗаполнено(СтрокаДерева) Тогда
						КоллекцияСтрокВариантов.Удалить(СтрокаДерева);
					КонецЕсли;
					
				ИначеЕсли Выборка.ТипПроцесса = Перечисления.ДФ_ТипыПроцессов.ДругиеВарианты Тогда
					
					СтрокаДерева = КоллекцияСтрокВариантов.Найти("ДругиеВариантыСозданияПроцессов", "Вариант");
					Если ЗначениеЗаполнено(СтрокаДерева) Тогда
						КоллекцияСтрокВариантов.Удалить(СтрокаДерева);
					КонецЕсли;
					
				КонецЕсли;
				
			КонецЕсли;
			
		КонецЦикла;
		
	КонецЕсли;
	
КонецПроцедуры

 

Обновление 2.1.19.22:

- Поднят режим совместимости расширения до версии 8.3.14.

- Функции расширения переведены на новую версию конфигурации.

Данное расширение тестировалось на версии 2.1.19.22 1С:Документооборот КОРП.

Скачать файлы

Наименование Файл Версия Размер
Дополнительные функции для 1С:Документооборот.:

.cfe 244,69Kb
22.01.20
28
.cfe 2.1.19.22 244,69Kb 28 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. oberonm 9 24.01.20 08:10 Сейчас в теме
А не Лушникова ли это модули?
2. pavelpribytkin96 276 24.01.20 10:50 Сейчас в теме
(1)Нет) Видел его расширение, если будут ещё проекты по ДО, тогда обязательно возьму его. Все модули самописные.
3. Svet_Serg 26.02.20 15:01 Сейчас в теме
Если значение реквизита равно "Истина", тогда задача "Ознакомиться с результатом согласования" создаваться не будет.


Правильно понимаю, на утверждение и регистрацию это не распространяется?
4. pavelpribytkin96 276 27.02.20 09:26 Сейчас в теме
5. OlegBog1971 24 20.06.20 17:17 Сейчас в теме
Добрый день.
Добавили вашу разработку себе в ДО КОРП 2.1.20.5
Активировали доп.функцию - Автоматическое обновление файлов данными владельца
При проведении регистрации документа, когда по идее в шаблон файла должен добавится реквизиты номер и дата - возникает ошибка.
Если деактивировать доп.функцию, то все работает (без автоматического обновления)
Прикрепленные файлы:
6. pavelpribytkin96 276 20.06.20 19:12 Сейчас в теме
(5)Дорбрый день.

На данный момент эта функция работает только при включенной опции "Изменять файлы Microsoft Word (doc docx) только на сервере.
В статье об этом не написано, постараюсь исправить в свободное время.
Приношу извинения за доставленные неудобства.
7. OlegBog1971 24 21.06.20 09:27 Сейчас в теме
(6) а в вашей публикации //infostart.ru/public/1120532/ будет работать?
8. pavelpribytkin96 276 21.06.20 17:41 Сейчас в теме
(7)
infostart.ru/public/1120532

Нет.
Проверил на новой версии. Шаблоны формата "doc" не заполняются даже при включенной опции "Изменять файлы Microsoft Word (doc docx) только на сервере" с помощью типовой команды (на более старой версии платформы и ДО таких проблем не возникало, заполнение шаблонов "doc" работало корректно при вызове с сервера). В моей базе корректное заполнение шаблонов формата "doc" выполняется только если вызывать заполнение файлов с клиента (в типовой команде "Заполнить файлы данными документа" идет вызов с сервера). Все базы, на которых я выполнял проверку типовые (платформа 8.3.17.1496, версия ДО - 2.1.21.12, база серверная).

Подскажите, пожалуйста, какого формата шаблон файла в Вашей базе?
Рекомендую использовать шаблоны формата "docx". При использовании шаблонов формата "docx" во-первых заполнение шаблона файла будет выполняться в разы быстрее, во-вторых, не будет ошибок при обновлении файлов данными документа в типовой базе и функция из расширения будет работать корректно вне зависимости от значения константы "Изменять файлы Microsoft Word (doc docx) только на сервере".
Оставьте свое сообщение

См. также

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    19672    4    m-rv    86    

Отключение создания задачи ознакомления для бизнес-процесса "Согласование" в 1С: Документооборот

Практика программирования Документооборот и делопроизводство v8 v8::Бизнес-процессы ДО Абонемент ($m)

В данной публикации я хочу поделиться расширением, с помощью которого можно отключить создание задачи ознакомления для бизнес-процесса "Согласование" в 1С: Документооборот.

1 стартмани

30.11.2019    5881    12    pavelpribytkin96    5    

Автоматическое обновление файлов данными владельца в документообороте

Практика программирования v8 ДО Бесплатно (free)

Обновление данных файлов, созданных по шаблону в ДО 2.1.13.

10.09.2019    3535    pavelpribytkin96    4    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    23500    22    Stepa86    45    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    29768    86    m-rv    57    

Алгоритмы поиска пути в графе

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Реализуем алгоритмы поиска пути в графе на платформе 1С 8.3, такие как алгоритм А*, поиск в ширину, жадный поиск, алгоритм Дейкстры и вконце волновой.

1 стартмани

09.07.2019    16879    11    RonX01    10    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    21064    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    35554    54    dsdred    15    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    27503    19    mvxyz    17    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    27301    26    informa1555    26    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    45119    17    kalyaka    16    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    29773    11    SITR-utyos    13    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    26933    69    vasvl123    9    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    26373    50    kwazi    6    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    43312    12    swimdog    41    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    31523    132    PLAstic    59    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    47380    36    Demanoidos    60    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    22127    21    sasha777666    63    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    125703    13    signum2009    48    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    30652    112    romasna    49    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    50576    35    ildarovich    41    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    27912    123    kiv1c    18    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    21366    104    Alxby    23    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    20425    94    igel9780    22    

Хранение файлов в томах на диске (для УПП 1.3) Промо

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    56040    8    wowik    32    

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

Практика программирования WEB v8 1cv8.cf Россия Абонемент ($m)

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    24774    16    Anton64    22    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    35959    95    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    25969    134    Stepa86    15    

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации

Управление бизнес-процессами (BPM) Обработка документов Обработка справочников Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf БП3.0 КА2 УУ Абонемент ($m)

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    53521    262    BlizD    206    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    27425    76    ZhokhovM    60    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    59834    177    rozer    64    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    56549    19    arakelyan    18    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    33785    48    ildarovich    23    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    79030    155    igo1    54    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    17729    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    48896    50    yuraos    17    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    53435    173    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    22707    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    36517    19    milkers    4    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    55745    47    YPermitin    19    

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram

Практика программирования Внешние источники данных v8 1cv8.cf Абонемент ($m)

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    90558    456    Luchik    202