Соответствие пользователей Информационной базы и Актив директория

Публикация № 1184427

Разработка - Системная интеграция - Интеграция

Предлагаю Вашему вниманию обработку используемую в реальном производственном процессе на нашем предприятии. Эта обработка предназначена для сопоставления пользователей в Информационной базе и пользователей в Актив директории. Пользователи в Информационной базе должны быть прописаны в Актив директории, но иногда получается так, что либо пользователь в Актив директории отсутствует вообще, либо введен в Информационную базу с ошибкой (что равнозначно).

Обработка предназначена для работы в клиент-серверных базах и тестировалась на платформе 8.3.14.1854. 

Работает в режиме внешней обработки. 

Перейдем к рассмотрению программного кода.

    Обработка небольшая и состоит из нескольких функций и одной процедуры, коды которых я коротко опишу.

1. Процедура запуска , она последовательно запускает на выполнение функции и процедуры обработки.

Код процедуры:
    

&НаКлиенте
Процедура ПолучитьПользователейИБ(Команда)
	МассивЛогинов=Новый Массив;
	МассивДоменов=Новый Массив;
	
	МассивЛогинов=ПолучитьПользователейИБ1();
	МассивДоменов=ПолучитьДоменыИБ1();
	ПолучитьПользователяИзАД1(МассивЛогинов,МассивДоменов);
	ЗаполнениеОтличиеИБотАД();
КонецПроцедуры


2. Процедура ИнструкцияПоЭксплуатации при нажатии соответствующей кнопки выводит текст инструкции.

Код процедуры:
    

&НаКлиенте
 Процедура ИнструкцияПоЭксплуатации(Команда)
//Процедура выводит текстовый файл Инструкция по эксплуатации	 
	Инструкция="          Инструкция на обработку ПользователиИБвАД ."+Символы.ПС+" 
	|Обработка проверяет наличие всех пользователей Информационной Базы в Актив Директории."+Символы.ПС+"
	|1. Закладка ""ПользователиИБ"" отобпажает всех пользователей ИБ."+Символы.ПС+"
	|2. Закладка ""ПользователиАД"" отображает пользователей ИБ найденных в АД"+Символы.ПС+"
	|3. Закладка ""Отличие ИБ от АД"" отображает пользователей ИБ которых нет в АД и отличие пользователей ИБ и АД.";

	Предупреждение(Инструкция);

КонецПроцедуры

3. Функция ПолучитьПользователейИБ1 выбирает всех пользователей Информационной Базы, заполняет таблицу Пользователи и 
Возвращаемый массив МассивЛогинов1. Данные таблицы используются на закладке формы ПользователиИБ.
 


Код Функции:
    

&НаСервере
Функция ПолучитьПользователейИБ1()
//Выбираем всех пользователей ИБ, заполняем таблицу Пользователи и Возвращаемый массив МассивЛогинов1************************************************
	МассивЛогинов1=Новый Массив;
	ИмяДоменаАД="";                                        
	ЛогинАД="" ;
	ПолноеИмяПользователяАД="";

	Буква="";
	ЛогинИБ="";                                     
	Домен="";
	НомерПользователя=1;
	ПредидущийДомен="";
	СчетчикБукв=3;
	СчетчикДоменов=1;
	МассивПользователей= ПользователиИнформационнойБазы.ПолучитьПользователей();   //Встроенной функцией получаем массив пользователей Выборка
	Для Каждого ЭлементМассива Из МассивПользователей Цикл                         //Через цикл просматриваем массив Выборка по ключевому параметру Логин
		СчетчикБукв=3;
		ФлагДоменЛогин="Домен";
		ДоменЛогин=ЭлементМассива.ПользовательОС;                                  //Выбираем из массива пользователей значение ПользовательОС это ДоменЛогин
		ПолноеИмяПользователя=ЭлементМассива.ПолноеИмя;                            //Выбираем из массива пользователей значение ПолноеИмя
		ПользовательУникльныйИдентификатор=ЭлементМассива.УникальныйИдентификатор; //Выбираем из массива пользователей значение УникальныйИдентификатор
		
		Запрос = Новый Запрос;                                                     //Определяем текущего пользователя в справочнике Пользователи 
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	Пользователи.Наименование КАК Наименование,
		|	Пользователи.ПометкаУдаления КАК ПометкаУдаления
		|ИЗ
		|	Справочник.Пользователи КАК Пользователи
		|ГДЕ
		|	Пользователи.ИдентификаторПользователяИБ = &ПользовательУникльныйИдентификатор"
		;
		Запрос.УстановитьПараметр("ПользовательУникльныйИдентификатор",ПользовательУникльныйИдентификатор);
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();                                
		Пока Выборка.Следующий() Цикл
			НаименованиеВСправочнике=Выборка.Наименование;
			Если Выборка.ПометкаУдаления=Ложь Тогда
				ПометкаУдаленияПользователя = "Действует";                          //Записываем результат ПометкаУдаления
			Иначе
				ПометкаУдаленияПользователя = "Удален";
			КонецЕсли;		
		КонецЦикла; 
		
		Буква=Сред(ДоменЛогин,СчетчикБукв,1);
		Пока НЕ	Буква="" Цикл                                                       //В цикле преобразуем в необходимый вид Домен, ЛогинИБ, ПолноеИмяПользователя 
			Если НЕ Буква="\" Тогда
				Если ФлагДоменЛогин="Домен" Тогда
					Домен=Домен+Буква;
				КонецЕсли;
				
				Если ФлагДоменЛогин="Логин" Тогда
					ЛогинИБ=ЛогинИБ+Буква;                            
				КонецЕсли;
				
			Иначе
				ФлагДоменЛогин="Логин";	
			КонецЕсли;
			СчетчикБукв=СчетчикБукв+1;
			Буква=Сред(ДоменЛогин,СчетчикБукв,1);
		КонецЦикла;
		Строка=Пользователи.Добавить();                                            //Добавляем в таблицу Пользователи строку с параметрами пользователя
		Строка.Номер=НомерПользователя;
		Строка.Домен=Домен;                                        
		Строка.Логин =ЛогинИБ ;
		Строка.ФИО=ПолноеИмяПользователя;
		Строка.ПометкаУдаления=ПометкаУдаленияПользователя;
		Строка.НаименованиеВСправочникеПользователи=НаименованиеВСправочнике;
		
		МассивЛогинов1.Добавить(ЛогинИБ);                                         //Добавляем в возвращаемый массив логин пользователя в Информационной базе
		
		НомерПользователя=НомерПользователя+1;
		
		ПредидущийДомен=Домен;
		
		ФлагДоменЛогин="Домен";
		ЛогинИБ="";                                 
		Домен="";
	КонецЦикла;
	Возврат МассивЛогинов1;

КонецФункции


4. Функция ПолучитьДоменыИБ1 получает список доменов в МассивДоменов1, это необходимо для просмотра пользователей
в Актив Директории.

Код Функции:
            

&НаСервере
Функция ПолучитьДоменыИБ1()
//Заполняем возвращаемый массив	МассивДоменов********************************************************************************************************
	МассивДоменов1=Новый Массив;
	ПустойДомен="";
	СчетчикДоменов=1;
	Запрос = Новый Запрос;
	ПИБ = РеквизитФормыВЗначение("Пользователи",Тип("ТаблицаЗначений"));           //Выгружаем Табличный реквизит формы в переменную
	МВТ=Новый МенеджерВременныхТаблиц;                                             //Создаем МенеджерВременныхТаблиц
	Запрос.МенеджерВременныхТаблиц=МВТ;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ПИБ1.Домен КАК Домен
	|ПОМЕСТИТЬ ВТДанные
	|ИЗ
	|	&ПИБ1 КАК ПИБ1
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	ВТДанные.Домен КАК Домен
	|ИЗ
	|	ВТДанные КАК ВТДанные
	|ГДЕ
	|	ВТДанные.Домен <> &ПустойДомен
	|
	|СГРУППИРОВАТЬ ПО
	|	ВТДанные.Домен"
	;
	Запрос.УстановитьПараметр("ПустойДомен",ПустойДомен);
	Запрос.УстановитьПараметр("ПИБ1",ПИБ);
	РезультатЗапроса = Запрос.Выполнить();
	Выборка = РезультатЗапроса.Выбрать();                                
	Пока Выборка.Следующий() Цикл                                                 //Выбираем результат запроса в возвращаемый массив МассивДоменов1
		МассивДоменов1.Добавить(Выборка.Домен);
	КонецЦикла;   
	Возврат МассивДоменов1;
				
  КонецФункции
 

5. Процедура ПолучитьПользователяИзАД1 получает пользователей в Актив Директории и помещает их в таблицу ПользователиАД .
Данные таблицы используются на закладке формы ПользователиАД.
 


Код процедуры:
 

&НаКлиенте
Процедура ПолучитьПользователяИзАД1(МассивЛогинов,МассивДоменов)
//Процедура заполняет таблицу ПользователиАД, из АД заносим ФИО, Логин*******************************************************************************	
//Достаем значение Логина
НомерПользователя=0;

Для Каждого ЭлементМассива из МассивЛогинов Цикл
	ЛогинИБ=ЭлементМассива; 
	Если НЕ ЛогинИБ="" Тогда		
		ЛогинПользователя=СокрЛП(ЛогинИБ);
//Комутирум Active Directory для извлечения данных о пользователе
		КомандаАДО    = Новый COMОбъект("ADODB.Command");
		СоединениеАДО = Новый COMОбъект("ADODB.Connection");
		СоединениеАДО.Provider = "ADSDSOObject";
		Попытка
			СоединениеАДО.Open("Active Directory Provider");    
		Исключение
			Сообщить("Ошибка при открытии Active Directory Provider: " + ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		
		КомандаАДО.ActiveConnection = СоединениеАДО;
		
//Получаем имя домена к которому принадлежит данный компьютер 
		Попытка
			RootDSE = ПолучитьCOMОбъект("LDAP://RootDSE");
		Исключение
			Сообщить("Ошибка ПолучитьCOMОбъект(LDAP://RootDSE): " + ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		СчетчикДоменов=0;
		ПолноеИмяПользователя="";
		ИндексДомена=0;
		ФлагЦиклаДомена=0;
		ФлагПользователя=0;
		Для Каждого ЭлементМассива из МассивДоменов Цикл
			ТекущийДомен=ЭлементМассива;
//			Если ВРег(ТекущийДомен)="KRG" Тогда
//				ТекущийДомен="DC=krg,DC=mrg,DC=ru";
//			Иначе
				ТекущийДомен=ТекущийДомен+".local";
//			КонецЕсли;
			
			CommandText = " 
			|SELECT 
			|    AdsPath
			|FROM 'LDAP://" +ТекущийДомен + "'
			|WHERE 
			|    objectCategory = 'user'
			|    and objectClass = 'person'
			|    and SAMAccountName = '" + ЛогинПользователя + "'
			|";
			
			Попытка
				ВыборкаАДО = СоединениеАДО.Execute( CommandText); 
				ПутьОбъекта = ВыборкаАДО.Fields("AdsPath").Value;
				ОбъектАД = ПолучитьCOMОбъект(ПутьОбъекта);
				ЛогинАД= ОбъектАД.sAMAccountName;
				ПолноеИмяПользователя=ОбъектАД.cn;
				Если ЛогинАД=""  Тогда                                                  //Проверяем выборку на пустое значение , если ЛогинАД пуст пропускаем эту строку 
					ФлагЦиклаДомена=1;
				КонецЕсли;
			Исключение
				ФлагЦиклаДомена=1;
			КонецПопытки;
			Если  ФлагЦиклаДомена=0 Тогда                                               //Проверяем был ли найден пользователь в домене 
				
				НомерПользователя=НомерПользователя+1;
						
				Строка=ПользователиАД.Добавить();
				Строка.ЛогинИБ =ЛогинИБ ;
				Строка.Номер=НомерПользователя;
				Строка.Домен=ТекущийДомен;                                        
				Строка.Логин =ЛогинАД ;
				Строка.ФИО=ПолноеИмяПользователя;
				
				Сообщить("Пользователь"+ПолноеИмяПользователя+" найден в АД."); 
				
				
				ИмяДомена="";
				ЛогинАД="";
				ПолноеИмяПользователя="";
				ВыборкаАДО.Close();
				Прервать;
			КонецЕсли;	
			ФлагЦиклаДомена=0;
			ИндексДомена=ИндексДомена+1;
		КонецЦикла;		
		ФлагПользователя=0;
		СоединениеАДО.Close();
	КонецЕсли;	
КонецЦикла;

КонецПроцедуры

 

6. Процедура ЗаполнениеОтличиеИБотАД заполняет таблицу ОтличиеИБотАД, которая используются на закладке формы ОтличиеИБотАД.
 


Код процедуры:
 


&НаКлиенте
Процедура ПолучитьПользователяИзАД1(МассивЛогинов,МассивДоменов)
//Процедура заполняет таблицу ПользователиАД, из АД заносим ФИО, Логин*******************************************************************************	
//Достаем значение Логина
НомерПользователя=0;

Для Каждого ЭлементМассива из МассивЛогинов Цикл
	ЛогинИБ=ЭлементМассива; 
	Если НЕ ЛогинИБ="" Тогда		
		ЛогинПользователя=СокрЛП(ЛогинИБ);
//Комутирум Active Directory для извлечения данных о пользователе
		КомандаАДО    = Новый COMОбъект("ADODB.Command");
		СоединениеАДО = Новый COMОбъект("ADODB.Connection");
		СоединениеАДО.Provider = "ADSDSOObject";
		Попытка
			СоединениеАДО.Open("Active Directory Provider");    
		Исключение
			Сообщить("Ошибка при открытии Active Directory Provider: " + ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		
		КомандаАДО.ActiveConnection = СоединениеАДО;
		
//Получаем имя домена к которому принадлежит данный компьютер 
		Попытка
			RootDSE = ПолучитьCOMОбъект("LDAP://RootDSE");
		Исключение
			Сообщить("Ошибка ПолучитьCOMОбъект(LDAP://RootDSE): " + ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		СчетчикДоменов=0;
		ПолноеИмяПользователя="";
		ИндексДомена=0;
		ФлагЦиклаДомена=0;
		ФлагПользователя=0;
		Для Каждого ЭлементМассива из МассивДоменов Цикл
			ТекущийДомен=ЭлементМассива;
//			Если ВРег(ТекущийДомен)="KRG" Тогда
//				ТекущийДомен="DC=krg,DC=mrg,DC=ru";
//			Иначе
				ТекущийДомен=ТекущийДомен+".local";
//			КонецЕсли;
			
			CommandText = " 
			|SELECT 
			|    AdsPath
			|FROM 'LDAP://" +ТекущийДомен + "'
			|WHERE 
			|    objectCategory = 'user'
			|    and objectClass = 'person'
			|    and SAMAccountName = '" + ЛогинПользователя + "'
			|";
			
			Попытка
				ВыборкаАДО = СоединениеАДО.Execute( CommandText); 
				ПутьОбъекта = ВыборкаАДО.Fields("AdsPath").Value;
				ОбъектАД = ПолучитьCOMОбъект(ПутьОбъекта);
				ЛогинАД= ОбъектАД.sAMAccountName;
				ПолноеИмяПользователя=ОбъектАД.cn;
				Если ЛогинАД=""  Тогда                                                  //Проверяем выборку на пустое значение , если ЛогинАД пуст пропускаем эту строку 
					ФлагЦиклаДомена=1;
				КонецЕсли;
			Исключение
				ФлагЦиклаДомена=1;
			КонецПопытки;
			Если  ФлагЦиклаДомена=0 Тогда                                               //Проверяем был ли найден пользователь в домене 
				
				НомерПользователя=НомерПользователя+1;
						
				Строка=ПользователиАД.Добавить();
				Строка.ЛогинИБ =ЛогинИБ ;
				Строка.Номер=НомерПользователя;
				Строка.Домен=ТекущийДомен;                                        
				Строка.Логин =ЛогинАД ;
				Строка.ФИО=ПолноеИмяПользователя;
				
				Сообщить("Пользователь"+ПолноеИмяПользователя+" найден в АД."); 
				
				
				ИмяДомена="";
				ЛогинАД="";
				ПолноеИмяПользователя="";
				ВыборкаАДО.Close();
				Прервать;
			КонецЕсли;	
			ФлагЦиклаДомена=0;
			ИндексДомена=ИндексДомена+1;
		КонецЦикла;		
		ФлагПользователя=0;
		СоединениеАДО.Close();
	КонецЕсли;	
КонецЦикла;

КонецПроцедуры

 

Обработка особенно актуальна для случая когда пользователи имеют аутентификацию 
операционной системы и работают через консоль.

Скачать файлы

Наименование Файл Версия Размер
Соответствие пользователей Информационной Базы и Актив Директория.:

.epf 12,02Kb
23.01.20
3
.epf 12,02Kb 3 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP) Промо

Загрузка и выгрузка в Excel Внешние источники данных Интеграция v8 ERP2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    44048    5    milkers    2    

Формирование файла загрузки реализаций для сайта sti.gov.kg

Интеграция Налоговые v8 БП1.6 Кыргызстан НУ НДС Абонемент ($m)

Обработка предназначена для старых версий БП для Кыргызстана 1.6 и 1.7

1 стартмани

18.09.2020    451    0    Fox-trot    0    

Загрузка выручек касс по API с 1-ОФД (1-OFD.RU)

Обработка документов Кассовые операции ККМ Интеграция v8 Розница Абонемент ($m)

Обработка позволяет формировать отчеты о розничных продажах средствами API с 1-ОФД (1-OFD.RU)

2 стартмани

18.09.2020    508    0    ketr    0    

Загрузка из Frontol. Расширение для БП (КОРП)

Интеграция ККМ Адаптация типовых решений v8 v8::БУ БП3.0 Абонемент ($m)

Простое расширение для загрузки продаж и кассовых операций из систем Frontol. Может использоваться как основа для более полной интеграции

3 стартмани

10.09.2020    562    0    pbabincev    0    

Модуль для работы 1С (платформа 8.2 и выше) с внешними SOAP Web-сервисами Промо

Внешние источники данных WEB Интеграция v8 1cv8.cf Абонемент ($m)

Модуль для работы 1С (платформа 8.2 и выше) с внешними Web-сервисами, реализованными по протоколу SOAP.

2 стартмани

15.02.2016    39452    84    lunjio    15    

Конструктор Json Schema с функцией валидации JSON

Обмен данными 1С WEB Интеграция Языки и среды v8 1cv8.cf 1С:Франчайзи, автоматизация бизнеса Абонемент ($m)

Инструмент для создания Json-схем по формату 4 драфта. В современном мире модно пользоваться Http-сервисами и Json, но если для старого доброго xml все уже придумано и xsd схемы можно рисовать в 1С из коробки, то с json и его форматом Json schema все не так хорошо. Зачастую нужно стандартизировать формат сообщений обмена json и для этого можно воспользоваться Конструктором. Есть возможность проверить свой Json на соответствие схеме. Схемы после выгрузки проходят валидацию в Liquid studio 2020. Стандартизируйте обмен Json с комфортом и удобством.

1 стартмани

16.07.2020    2713    7    Segate    5    

IoT (Internet of Things) в 1С или как подружить 1С с ESP32 при помощи MQTT-брокера

WEB Интеграция Интернет вещей (IIoT) Системная интеграция v8 Абонемент ($m)

Что делать, если надо подключить удалённое устройство к серверу 1С, но ни устройство, ни сервер 1С нельзя "светить" наружу? А если таких устройств десятки или сотни по всей стране? Ответ: Использовать промежуточный сервис, который будет пересылать данные между сервером 1С и устройствами. Такие функции замечательно выполняет MQTT-брокер, но вот не задача, 1С не умеет с ним работать.

1 стартмани

25.06.2020    3688    6    frutty    5    

Интеграция АЗС ТОПАЗ и Штрих-М Магазин

Внешние источники данных Интеграция v8 1cv8.cf Россия Абонемент ($m)

Обмен данными между АЗС Топаз 3.14 и 1С на примере Штрих-М: Магазин, редакция 5.1 (5.1.6.8).

1 стартмани

17.06.2020    1129    1    Ignatov_mu    0    

7 причин, почему интеграция стала приятной. Не упускайте ряд потрясающих возможностей Промо

Внешние источники данных Интеграция Мобильная разработка v8 1cv8.cf Абонемент ($m)

В статье показаны примеры получения данных без программирования на стороне «1С:Предприятие 8». Вам нужно проверить гипотезу и проанализировать данные, почему бы не интегрироваться с Excel? Используете технологии .NET и «1С:Предприятие 8», процесс связывания систем движется катастрофически медленно? Хотите native Android приложение с вашими данными всегда под рукой?

1 стартмани

01.10.2015    56216    45    pbazeliuk    23    

Автоматическая загрузка накладных от поставщиков из электронной почты (Розница 2.2)

Обработка документов Розничная торговля Учет ТМЦ Интеграция Email v8 Розница Россия УУ Абонемент ($m)

Данная обработка предназначена для получения файлов (*.xls;*.xlsx;*.ods;*.dbf) с почтового сервера вашей электронной почты и загрузки прочитанных данных в документы «Поступление товаров». Так же присутствует возможность распаковки архивов, если поставщик шлет вам в письме архивированные файлы (RAR; ZIP; 7Z). Наличие установленного MS Office и Open Office не требуется.

5 стартмани

18.05.2020    1871    1    StiVitS    2    

Сканирование магнитных карт (python) и миграция данных в 1С (http - сервис)

Практика программирования Интеграция v8 1cv8.cf Абонемент ($m)

Скрипт чтения com порта (python) и расширение (*.cfe) для приема пакета сообщений в json.

1 стартмани

06.05.2020    1475    0    Legavaz    0    

И еще раз о HTTP-сервисах

WEB Внешние источники данных Интеграция v8 БП3.0 ЗУП3.x Россия Абонемент ($m)

Как разработать  подсистему обмена  с сильно ограниченными правами доступа к базе вопрошающего субъекта с использованием различных вариантов маршрутизации.

10 стартмани

28.04.2020    4344    7    zavsom    2    

1C + jabber + python Промо

Сервисные утилиты Практика программирования Интеграция v8 1cv8.cf ДО Абонемент ($m)

Отправка сообщений в jabber из 1С [Документооборота] при помощи python-скрипта.

1 стартмани

14.04.2014    26034    10    Mogidin    2    

Примеры запросов с календарем Outlook через EWS

Интеграция v8 v8::УФ 1cv8.cf Абонемент ($m)

Примеры создания/изменения/получения/удаления событий календаря Outlook пользователя из 1С через EWS.

2 стартмани

23.04.2020    1803    10    77dream77    0    

DaJet QL - расширяемый язык запросов

Интеграция WEB v8 Абонемент ($m)

DaJet QL поддерживает практический полный синтаксис SQL Server 2005-2016. Кроме этого это расширяемый язык запросов. Обращение к объектам СУБД выполняется в терминах метаданных 1С. Доступ к возможностям этого языка запросов реализован в виде web api сервиса. Результаты запросов возвращаются в виде JSON.

1 стартмани

20.04.2020    6135    9    zhichkin    16    

Включение и выключение электроприборов из 1С

Интеграция v8 Абонемент ($m)

В публикации я постараюсь описать, как в случае необходимости можно расширить возможности 1С при помощи доступного внешнего оборудования. Рассмотрим, каким образом можно легко включать и выключать электроприборы программно из 1С или имитировать нажатие кнопок.

1 стартмани

02.04.2020    5134    4    bobreks    66    

Все параметры интеграции в одном справочнике

Интеграция v8 Абонемент ($m)

Демо-база для удобного хранения всех параметров интеграции в одном месте и быстрой их замены тестовыми в тестовых базах автоматически. Идея избавляет от ручной смены параметров в тестовых базах; особенно упрощает работу, когда таких параметров значительно много.

3 стартмани

05.03.2020    1678    0    info1i    0    

Пример связи с API Диадок через сертификат

Интеграция v8::ОУ v8::УФ УТ11 Россия Абонемент ($m)

Обработка для связи с API Диадок через сертификат формата X.509 - пример подключение при двухфазной аутентификации по сертификату+получение организаций.

1 стартмани

17.02.2020    1819    3    2vadmaster    0    

Интеграция ЗУП с порталом обучения TeachBase

WEB Интеграция v8 ЗУП3.x Россия УУ Абонемент ($m)

Расширение-заготовка для интеграции с TeachBase.

1 стартмани

17.02.2020    1741    1    maksip    0    

Пример http-интеграции ЗУП и HR-портала

Интеграция WEB Расширения v8 v8::СПР ЗУП3.x Россия Абонемент ($m)

Расширение для ЗУПа с http-сервисами для интеграции с HR-порталом.

1 стартмани

12.02.2020    2833    1    maksip    5    

Redmine 1C - почти коробка

Управление командой Управление задачами Интеграция v8 Абонемент ($m)

Почему это решение называется «почти коробка»? Потому, что это почти коробочное решение. С его помощью, просто добавив подсистему в конфигурацию, уже можно начинать взаимодействовать с системой Redmine.

10 стартмани

10.02.2020    4864    6    zfilin    9    

Интеграция с API Remonline

Обмен данными 1С WEB Интеграция Облачные сервисы, хостинг Расширения v8 v8::УФ 1cv8.cf Абонемент ($m)

Расширение для работы с веб-сервисом Remonline.

2 стартмани

05.02.2020    2545    3    Johny_v    0    

Интеграция 1С с мессенджером WhatsApp через chat-api

Интеграция v8 1cv8.cf Россия Абонемент ($m)

Это не готовое решение для использования (разве что необходимо будет только массово отправлять сообщения получателям), данная разработка поможет быстрее понять, каким образом необходимо делать интеграцию 1С с мессенджером WhatsApp.

1 стартмани

23.01.2020    2920    23    Hawk_sib    1    

Внешние источники данных: создание таблиц в MS SQL с помощью скриптов *.sql

Внешние источники данных Интеграция v8 Абонемент ($m)

Как быть программисту 1С, если для интеграции базы 1С: Предприятие 8.3 есть техническое задание со стороны разработчика внешней базы данных. Но самой базы данных нет ? А она уже нужна: для отладки выгрузки данных. В тех.задании коллегами описана структура таблиц внешней базы данных. Тогда Вам можно создать такую базу данных самостоятельно. С помощью скрипта для MS SQL.

1 стартмани

21.01.2020    2789    1    Designer1C    5    

Пример взаимодействия 1С и Oracle Primavera

Обмен через XML Интеграция v8 ERP2 Абонемент ($m)

Эта разработка демонстрирует возможность связи 1С:ERP+PM Управление проектной организацией 2 и Oralce Primavera с использованием механизма веб-сервисов со стороны Primavera.

2 стартмани

04.11.2019    4811    7    sunnydragon777    0    

Интеграция с InSales. Обновление цен и остатков товаров

WEB Интеграция Ценообразование, прайсы v8 1cv8.cf Автомобили, автосервисы УУ Абонемент ($m)

Подсистема для интеграции с InSales. Реализация обновления цен и остатков товаров в каталоге на сайте через API. Данный пример реализован на конфигурации Альфа-Авто.

1 стартмани

18.10.2019    5303    11    leobrn    1    

Медовая стыковка с поддержкой входящих налоговых накладных (Украина)

Обмен данными 1С Интеграция v8 v8::УФ 1cv8.cf Украина БУ Абонемент ($m)

Доработка стандартного модуля интеграции 1С с Медком для возможности загрузки входящих налоговых накладных и расчетов корректировки.

1 стартмани

01.10.2019    3493    1    Gorus    0    

Интеграция 1С со сканерами отпечатка пальца ZKTime (обычные формы)

Интеграция v8 1cv8.cf Абонемент ($m)

Интеграция 1С со сканерами отпечатка ZKTime.

1 стартмани

07.08.2019    2919    3    Nefilimus    8    

Универсальная очередь интеграций 1С

Интеграция v8 Абонемент ($m)

"Универсальная очередь" это подсистема, которая позволяет осуществлять достоверную доотправку в случае неуспешно выполненной интеграции, а также выполнять интеграции в фоновом режиме. Очередь может иметь настройки расписания для каждой интеграции отдельно, хранит параметры отправки для каждого элемента очереди. Очередь можно использовать не только для интеграций, но и для выполнения любой процедуры в вашей конфигурации. В приложенном файле конфигурации содержится сама подсистема, а также примеры её использования.

1 стартмани

11.03.2019    6425    8    NovPas    6    

[dotPRICE.ru] Свой интернет-магазин - каждому!

Универсальные обработки WEB Интеграция Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 КА1 БП2.0 УТ10 Розница УПП1 УНФ БГУ Абонемент ($m)

Внешняя обработка позволяет любому пользователю 1С быстро создать собственный интернет-магазин (сервис онлайн-заказов, интернет-каталог продукции...)

1 стартмани

10.01.2016    27279    52    dotPRICE.ru    38    

Выгрузка маршрута в навигационную программу Navitel

Универсальные обработки Интеграция v8 1cv8.cf Абонемент ($m)

Предлагаю вашему вниманию процедуру выгрузки маршрута для навигационной программы Navitel (тестировалось на устройставх android), что может быть полезно например для того чтоб облегчить работу водителей доставки или торговых представителей.

1 стартмани

13.07.2014    22714    10    axilab    3    

Парсер веб-сайтов для 1С:Предприятие 8.3

Универсальные обработки WEB Интеграция v8 1cv8.cf Абонемент ($m)

Данная конфигурация является 1С-оберткой над проектом Abot, и тесно связанным с ним проектом: Html Agility Pack.

1 стартмани

22.02.2014    50170    115    Elisy    49